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Vocal Removal of Hip-Hop for MUS 499

Purpose:
The purpose of my project was to attempt to devise a method to remove 

vocal parts from hip-hop recordings in a rigorous, non-disruptive, and, if possible, 
automated method. I successfully removed vocals from a number of tracks with a 
high degree of accuracy, including Eminem's Lose Yourself, the Wu-Tang Clan's Wu-
Tang Clan Ain't Nothin' To F*** With, and Dr. Dre's Still D.R.E. (used as a test track). 
This method shows promise for vocal removal in future recordings, but automation 
has not been achieved.

Project Overview:
There is a major absence in 90s-era hip-hop music of high-quality and faithful 

instrumental recordings, even for famous and respected artists and producers. 
Although there is most definitely the same problem in modern hip-hop and rap 
music, modern releases are largely outside the scope of this project, due to reasons 
that will be discussed below. Thankfully, instrumental releases today are much more 
common and are on the rise, but notable and influential artists, such as the Wu-Tang 
Clan (many individual members included), The Notorious B.I.G., Warren G, De La 
Soul, Canibus, and many others have all been featured on singles, EPs, and albums 
that have never had official instrumental releases. 

Often, instrumental releases are no longer publishable due to label 
bankruptcy (perhaps not very surprisingly common among a label 
employee/producer demographic consisting of a large amount of gangsters and 
criminals), other loss of master recordings, or ongoing legal battles between 
producers and labels. Many recordings are self-released and the producer has no 
desire to publish an instrumental release, and although labels do occasionally 
release 20- or 25-year anniversary editions of albums, these are often extremely 
limited and difficult to listen to, even if one attempts to use, shall we say, less than 
savory websites. While there are a lot of low-quality basement MP3s available for 
listening online, these recordings are often of dubious origin and are also frequently 
192mbps or lower quality--not suitable for audiophile listeners. To this end, I was 
motivated to develop a method to produce bootleg high-quality instrumental 
versions of hip-hop tracks using the original releases as source material. 
Additionally, currently available software methods such as Audacity's Vocal 
Remover tool are very limited in scope and only work for select center-panned 
vocals recordings.

Although automation was not achieved, a method was developed using 
various tools available in the free audio analysis and editing software package 
Audacity that has effectively removed vocals from a number of hip-hop tracks with 
varying degrees of success, and shows promise for vocal removal in many other hip-
hop recordings and for multiple artists. 



The method, dubbed the "chop shop" method herein, involves the use of 
silence insertion and beat-matched samples of the drum loop used within a given 
track to construct a piecemeal user-defined "chopped" drum loop, leading to a 
"chopped track" with the intention of duplicating the drum loop found in the original 
track. This chopped track is then overlaid onto the original track and edited 
manually to match its drum loop as closely as possible, and the signal from each 
track is subtracted in order to obtain a vocals-only track. Finally, this vocals-only 
track, the "working track" produced using the original chopped loop, is edited 
further to remove noise used on records sampled during original recording, non-loop 
instrumentals and samples, and background vocals, and overlaid onto the original 
track once more to obtain an instrumental version. A defining characteristic of the 
chop shop method is that it is highly dependent on the individual artist and 
producer featured on a specific recording, and many additional steps must be 
undertaken to produce instrumental versions of some recordings than others.

Project Details:
Using Audacity tools, the chopped loop is assembled using ~15 different 

samples typically 0.02-1.5 seconds in length of the exposed drum loop of the 
original recording, with the goal for this chopped loop to closely match the original 
8- or 16-bar drum loop in a particular segment of the original recording. From the 
tracks I've worked on, a typical track has ~4 different melodic sections and 
therefore the same amount of chopped loops required, usually with different 
samples or instruments being used in each bridge and refrain and often with more, 
for reasons that will be elaborated on below. These samples are extracted from any 
exposed element of the drum beat present in the original recording, ie; a period of 
time during the original recording where a rapper takes a breath or drops out for a 
phrase, a full or partially instrumental bridge, or during an initial fade-in of a drum 
loop, and official scores or tabs are used where possible to determine whether the 
loop is in an 8- or 16-bar phrase (typical), or whatever rythmic repetition it may be 
in. 

The chopped loop is difficult and time-consuming to assemble manually for a 
number of reasons. Importantly, it can be quite painstaking to select individual 
samples listenable in the original recording that compose the drum loop of the 
piece--when I've used the chop shop method, these selections have been done by 
me, subjectively, and these are often indistinct and very short samples. If a piece 
has a completely instrumental bridge and a fade-in or fade-out of the main drum 
loop at the beginning or end, typical of Eminem and other Detroit producers, a 
chopped loop can be very easy to make, and will be composed of only a handful of 
individual samples. For some producers such as Snoop Dogg, the speed of vocal 
delivery and the lack of instrumental bridges makes chopped loops very difficult to 
generate.

After the "chops", or individual samples, have been selected, they must be 
looped. After determining the length of the loop, the chops are edited in Audacity 
and repeated under beat maching parameters to match the original drum loop in 
each individual melodic section. Once all the different sections have been combined 
and the loop has been assembled (details on the method are in the next section of 
this report), the first working track is obtained by using Audacity's Invert tool on the 



signal. If the editing is done correctly (something that takes many, many attempts), 
the signal present in the original track and the chopped track will partially but 
totally cancel each other out, leaving a working track composed of vocals, 
background vocals, and non-loop instruments. 

At this point, a good deal of further editing is required to the working track. 
It's likely to contain at least 3 or 4 producer-inserted non-loop samples, as well as 
background vocals and elements of the drum loop in each melodic section that 
weren't considered in the chopped track. In other words, if this first working track 
were again inverted to produce an instrumental version of the original recording, 
there would be no vocals, yes, but there would also be periods of total silence in the 
drum loop and many instruments and samples would be absent. The working track 
is refined usually ~5 times in order to more precisely match an a cappella 
arrangement of the original recording, with additional refinements made to the 
chopped track between each version. In this project, I've used my own best 
judgment to determine when a chopped track is finished and ready to be inverted 
onto the original.

 Once the final and most precise working track has been produced, it's edited 
onto the original track and inverted in order to obtain an instrumental track of high 
quality. Obviously, due to the limitations of sample selection used to construct 
chopped loops and the difficulty of inserting non-repeated samples and instrument 
parts into the working track, certain elements of the original recording that may 
belong in an instrumental version will not be reproduced using the chop shop 
method. However, when possible I've attempted to use various other production 
tricks, not covered here--such as Audacity's frequency analysis funtionality and 
other tools to segregate vocal-range signal from drum or synth signal--to maintain 
these elements in the instrumental versions I've produced.

The chop shop method is uniquely suited to produce instrumental versions of 
90s-era hip hop recordings due to the typical production style of that music and the 
instruments used by producers. Most, if not all, well-known producers active during 
this time played on some combination of MPC-12s or similar drum machines, loop 
pedals, and turntables. Due to the nature of the equipment, this style of production 
led to music that had perfectly repeated drum loops at a constant volume and a 
methodical and loop-dependent insertion and removal of instrumental parts, with 
little if any distortion or abrupt drop-in or drop-out of the backing drum loop. Modern 
hip hop production has increased in complexity and stylistic complexity immensely 
due to the presence of APCs and laptop production software, and producing an 
accurate chopped loop of a modern rapper's work would in many cases be 
immensely difficult or impossible. Due to these same difficulties, there are of course 
many 90s-era hip hop tracks that can't be used to produce instrumentals using the 
chop shop method, depending on the artist and album.

Methodology:
Presented here as a step-by-step list. Not all steps will be necessary in the  

production of an instrumental version from a particular track as discussed above.  
Steps for testing are also included. From the tracks I've worked on, the average  



length of time from start to finish to produce an instrumental version of an original  
track is ~9-14 hours, although this can vary widely.

1. Obtain Audacity at http://audacity.sourceforge.net/, and open it.
2. File>Open your hip-hop track of choice, vocals and all.
3. Select the track by left-clicking outside of the tracking area, under the 

crossfade and volume sliders.
4. Compress the two stereo halves of the track into a mono track with 

Tracks>Stereo Track To Mono.
5. Just in case, select the new mono track and use Tracks>Resample... at 

44.1kHz to ensure that the entire track is at the same sample rate--this is 
necessary to provide a recording that's at uniform sampling rate, and in most 
cases will not affect the studio recording at all. For the purposes of this paper, 
this is the original recording.

6. File>Save Project the original recording, and Open up a new blank 
Audacity project (or simply another track in the same project, your choice) to 
place the chopped loop in.

7. Begin collecting samples to compose the chopped loop. In the case of an 
instrumental fade-in or fade-out, an easy way to do this is to select that 
section of the original recording and attempt to use Effect>Fade In or 
Effect>Fade Out to oppose the original recording's volume, as appropriate. 
If that doesn't work, use Effect>Adjustable Fade to make the volume to as 
close to uniform as possible. Otherwise, any sample that contains no vocals 
will do, as long as it is placed properly within the chopped track. It's unlikely 
that samples of >1.5s will be suitable.

8. As samples are collected, select them then use Edit>Copy and Edit>Paste 
to move new samples into the chopped track. 

9. Between individual samples, use Generate>Silence to insert an appropriate 
amount of silence. Typically I insert ~0.05 seconds of silence as a baseline 
between individual samples, and then delete segments of silence as in step 
13 to refine the chopped loop.

10.Repeat the two above steps until a suitable drum track, with a length equal to 
one phrase of the drum loop in the original track, is obtained. Using the steps 
below, this loop will later be further refined and revisions will be made. When 
putting the chopped track together, Copy and Paste the loops as above in 
order to produce a chopped track, which will include sections of different 
chopped loops corresponding to the original track's melodic sections. Once a 
chopped loop for a given melodic section is completed, use 
Effect>Repeat...

11.Save your work and Open another new blank audacity project or track. This 
will house the working track.

12.First Paste your original track into this project, and then, in a separate track 
in this project, Paste the chopped track. Use Tracks>Align Tracks>Start 
to Zero to ensure that each track has the same start point.

13. If necessary, edit the working track using Effect>Change Tempo to more 
carefully align your working track with the original track (the easiest way to 
do this is by zooming out with View>Fit In Window to view the entire 
duration of the original track, then manually elongating the working track 
using Change Tempo until it is the same length), and remove silence 
between melodic sections of the working track to ensure each individual 



chopped loop section is in the appropriate position with respect to the original 
track. To remove silence from the working track, hold SHIFT and left-click two 
time points in the working track, then hit DELETE.

14.This is where the magic happens. Effect>Invert the track of your choice (I 
usually invert the chopped track, although this is arbitrary).

15.File>Export the overlaid original track and inverted chopped track--this is 
your working track.

16.As above, Open the working track and the original recording in the same 
project (or open a new project), and Invert the working track. 

17.If you've made a good working track, listening to the two mono tracks at the 
same time  will now simulate an instrumental track of the original recording! 
If that's the case, Export to your preferred audio format. 

18.If, as is more likely, your working track overlaid onto your original track and 
inverted results in incomplete vocal elimination, the chopped track must be 
refined. Go back to it.

19.This is the most time-consuming part of the entire process--the relative 
timings of samples from the original track within the chopped loops must 
match the original track precisely in order to properly cancel after being 
Inverted. Complicating this process, individual instruments present within 
the buildup/breakdown of the drum loop present in each melodic section 
must usually be accounted for in the chopped track used to construct the 
working track.

20.Repeat steps 7-17 as necessary to further refine the chopped track and 
working track. Typically, I attempt to add one "instrument" or sampled 
element of the drum loop at a time to each individual melodic section of the 
chopped track, and listen working track after each edit to determine what 
needs to be added to the chopped track. A perfect working track would be 
flawlessly a cappella and would have nothing in it except for main vocals. 

Obviously, a "perfect" instrumental version of an original recording will not be 
possible with the chop shop method--although in the author's opinion, some 
recordings subjected to my method can produce some very, very nice instrumental 
versions. A typical piece will require at least a couple dozen revisions to the working 
track (assuming one melodic section is revised at a time and one instrument is 
added at a time to the chopped track) in order to produce a mostly-clean 
instrumental version, and further edits will still be required at that point to 
accommodate individual musical elements as described above. Analyze>Silence 
Finder, Effect>Truncate Silence, Effect>Compressor, and Effect>Normalize, 
as well as all the tools described above, can be used to attempt to isolate individual 
samples and place them into the chopped track. 

Conclusion
In summary, the chop shop method has been used to successfully produce 

instrumental versions of several hip-hop recordings, some without official 
instrumental releases. The method is laborious and extremely time-consuming, 
however, if applied correctly it can be used to produce an almost flawless 
instrumental version of a lossless or high-quality original recording, making it 
superior in performance to most currently available vocal removal techniques. The 
method requires nothing except a high-quality original recording, a solid 



understanding of Audacity, and a large amount of the user's free time. Future work 
will focus on (if possible) automating this process through the use of Python or 
MATLAB script; looking at results of past years' submissions to MIREX, I see that 
there have been several attempts at automated vocal removal submitted there, 
with varying levels of success. 

The author wishes to thank Prof. Tipei for his rigorous and brain-tickling 
questions as to how this method might work, as well as providing several ideas for 
how it might be attempted and refined throughout the semester, as well as the 
other students of MUS 499, who each have their own awesome projects. 
Instrumental versions of the tracks mentioned in the first section of this report will 
be made available upon request, and several additional instrumentals will be 
attempted over the course of this summer and next semester. (Note that there is an 
official instrumental release of Dr. Dre's Still D.R.E.; this release was compared to 
the instrumental produced via the chop shop method and they were almost 
identical.)


